度量快速开发平台-专业、快速的软件定制快开平台

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 部件 流程 SQL
查看: 308|回复: 1

[分享] IIS7.0无法选择.net framework 3.5

[复制链接]

542

主题

5919

帖子

1万

积分

作者

Rank: 7Rank: 7Rank: 7

积分
13589
发表于 2018-7-15 17:58:40 | 显示全部楼层 |阅读模式
windows server 2008, iis7也才装上, 我的asp.net应用程序是.net3.5版本的,但是在设置iis7的时候,其应用程序池只能选择“.net framework 2.0”或者“无托管代码”,但是我又确实安装好了.net framework 3.5的,请问如何才能部署3.5的应用程序呢? IIS显示的是ASP.NET的版本,并不是.NET的版本.
Asp.net2.0支持net framework 3.5。选它就可以了。前提是你要装了net framework3.5
只本Asp.net2.0,本来就没3.x选项.是ASP.NET的版本
看来楼主把.net framework与asp.net 的版本混淆了。
一样一样 能用滴 装了,net framework3.5 就成
ASP.NET目前只到2.0版本,不可能有3.5,.NET Freamework和ASP.NET是不同的...
IIS里的.NET版本是Runtime版本,不论.NET 2.0、3.0、3.5、3.5sp1,都是2.0。
但如果你的程序用到了.NET 3.5的东西,则必须安装.NET 3.5,这是为了安装3.5扩展的那部分类库,而这些类库运行的时候依赖的还是CLR 2.0。

回复

使用道具 举报

542

主题

5919

帖子

1万

积分

作者

Rank: 7Rank: 7Rank: 7

积分
13589
 楼主| 发表于 2018-7-15 17:59:06 | 显示全部楼层
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|重庆度量科技  本站关键词:快速开发平台

GMT+8, 2018-9-18 22:04 , Processed in 0.259450 second(s), 27 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表