度量快速开发平台-业界最好的全功能软件开发平台

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 部件 流程 SQL
查看: 305|回复: 1

[分享] 需要 Oracle 客户端软件 8.1.7 或更高版本

[复制链接]

542

主题

5919

帖子

1万

积分

作者

Rank: 7Rank: 7Rank: 7

积分
13589
发表于 2017-12-21 14:22:09 | 显示全部楼层 |阅读模式
通过IIS配置网站后访问时提示如题的错误,可是Oracle数据库已经正常运行.问题出在哪里呢?
       这是Oracle的一个bug.因为Oracle安装在NTFS分区上,其访问权限受到限制,网上很多关于Win2000和2003的解决方案,在xp下有点不同.xp下的安全设置标签需要在安全模式下才可以设置,所以需要启动到安全模式.然后设置权限就可以解决问题.
win2003下的解决方案:

"System.Data.OracleClient 需要 Oracle 客户端软件 8.1.7 或更高版本"

出错的原因:
1.虽然报的是需要安装客户端8.1.7及以上版本但是并非这个,而是.net账户没有访问Oracle\bin文件夹的权限
2.windows2003操作系统安装在NTFS格式的盘中,如果是FAT32也就没有这个问题,看来NTFS格式在安全性这方面作的确实出色。
废话少说,还是看看我的解决方法吧。
1.在Oracle\bin文件夹上右键-------共享和安全------安全-----点击“添加”按钮,出现下面的界面
111.png


2.点击“高级”----“立即查找”,在下面显示的账户中选择“NTWORK SERVICE”(注意:IIS6中aspnet的账户是NTWORK SERVICE;而在IIS5中是aspnet。)
----将所有的权限都赋予----确定。
222.png

重新启动IIS和服务器即可。可以在“运行”中输入“IISRESET”。

回复

使用道具 举报

542

主题

5919

帖子

1万

积分

作者

Rank: 7Rank: 7Rank: 7

积分
13589
 楼主| 发表于 2017-12-21 14:22:55 | 显示全部楼层
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|重庆度量科技  本站关键词:快速开发平台

GMT+8, 2018-4-20 06:55 , Processed in 0.400245 second(s), 28 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表